HCIA_R&S-学习_Day03的副本

信息
の324
cpongo8808


参考博客【CSDN】

复习回顾

网络互联基础

  1. IP编址
    :已知192.168.11.3/28,计算该IP的子网是多少?广播地址是多少?可用IP有哪些?
  • 算跨度
    • 子网掩码为28,在24到32之间,所以基准值为32
    • 基准值-子网掩码=n=32-28=4
    • 跨度=2^n=2^4=16
  • 列出所有子网
    • 192.168.11.0
    • 192.168.11.16
    • 196.168.11.32
    • 196.168.11.48
  • 查看IP地址的范围
子网 广播地址 可用地址范围
192.168.11.0 192.168.11.15 192.168.11.1-192.168.11.14
192.168.11.16 192.168.11.31 192.168.11.17-192.168.11.30
192.168.11.32 192.168.11.47 192.168.11.31-192.168.11.46

  • 算出跨度之后,就可以得到每个子网,下一个子网主机位-1即为上一个子网的广播地址
  • 可用地址范围即除广播地址和网段外的所有地址

交换技术

  • 一台交换机可以划分2^12=4096个VLAN,取值为0-4095,保留位为0和4095,可用VLAN为1-4094,默认为1(所有端口)
  • 接口类型:
    • Access:接入链路,连接主机
    • Trunk:干道链路,连接交换机
    • Hybird:既可以连接主机也可以连接交换机
  • VLAN间的通信方式:
    • 单臂路由
    1. 将接口划入相应的VLAN
    2. 交换机与路由器的接口要配置成Trunk,允许VLAN通过
    3. 路由器划分子接口,并为子接口配置IP
    4. 路由器子接口需要封装对应的VLAN ID
    5. 路由器子接口开启ARP广播
    • 三层交换
    1. 起VLANIF的三层接口,配置IP地址(IP地址即为主机的网关地址)
  • STP:生成树
    • 构建生成树
    1. 选举根桥(ROOT):优先级(默认32768)、MAC,选值小的
    2. 选举根端口(RP):在非根交换机上选举根端口(COST,发送者的BID、PID,接受者的PID)
    3. 选举指定端口(DP):在网段上选举指定端口(COST,发送者的BID、PID,接受者的PID)
    4. 选举阻塞端口(AP):非根端口、非指定端口

路由协议基础与实现

VRP基础

交换机可以隔离冲突域,路由器可以隔离广播域。网络设备的增多使网络负担变重,可以通过华为专有的VRP系统来提升运行效率。通用路由平台VRP(Versatile Routing Platform)

  • 特点

    • 网络操作系统
    • 支持多种设备的软件平台(路由器、交换机、防火墙)
    • 提供TCP/IP的路由服务
  • PC和路由器的互联方式

    • console线
    • mini USB(需要安装驱动一端连接PC的USB接口,一端连接console口)
  • VRP的发展

命令行基础

<Huawei>system-view  //用户视图进入系统视图
[Huawei]  //系统视图
[Huawei]interface GigabitEthernet 0/0/0
[Huawei-GigabitEthernet0/0/0]  //接口视图
[Huawei-ospf-1]  //协议视图
  • sysname 修改设备名称
  • clock timezone BJ add 08:00:00设置所在时区
  • clock datetime 15:48:29 2020-03-31设置当前时间和日期
  • clock daylight-saving-time设置采用夏时制
  • display clock查看当前时间信息

以上命令都是在用户视图下使用

  • 命令等级
用户等级 命令等级 名称
0 0 访问级
1 0 and 1 监控级
2 0,1 and 2 配置级
3-15 0,1,2 and 3 管理级
  • 用户界面
    • console编号0,一个
    • VTY(Telnet登录)编号默认0-4,支持五个用户登录,最大可配范围0-14
  • 配置用户界面命令
    • idle-timeout设置超时时间
    • screen-length设置指定终端屏幕的临时显示行数
    • history-command max-size设置历史命令缓冲区的大小
  • 配置登录权限
    • user privilege配置指定用户界面下的用户级别
    • set authentication password配置本地认证密码
  • 配置文件查询
    • display current-configuration显示当前配置文件
    • display saved-configuration显示保存的配置文件
    • save保存当前配置信息
    • reset saved-configuration清除下次启动时加载的配置文件

IP路由基础

路由:源到目标网络所经过的路径

  • 自治系统(AS):由同一个管理机构管理、使用统一路由策略的路由器集合

  • 路由选路:路由器负责为数据包选择一条最优路径,并进行转发

  • 路由类型:

    • 静态路由
    • 动态路由
    • 直连路由

路由协议

  • 按作用分类:
    • IGP:内部网关路由协议,企业内部所运行的路由协议
    • BGP:外部网关路由协议
  • 按算法分类:
    • 距离矢量型的路由协议:RIP、BGP
    • 链路状态的路由协议:OSPF、ISIS

优先级

协议 优先级
DIRECT 0
OSPF 10
ISIS 15
静态 60
RIP 100
OSPF-ASE 150
  • IP路由表

命令display ip routing-table查看路由表

  • Destination/Mask:目的网段/掩码
  • Proto:路由协议(Static是指静态路由,Direct是指直连路由)
  • Pre:路由协议的优先级
  • Cost:开销
  • NextHop:下一跳
  • Interface:转发接口
  • 最长匹配原则:
    • 路由表中有多个匹配目的网络的路条目时,路由器会选择掩码最长的条目
  • 路由的度量
    • 即为COST值,从源到目标经过路径的花费(开销)

静态路由基础

静态路由是指手动配置和维护的路由

  • 静态路由
    • 在广播型的接口上配置静态路由时,必须指定下一跳
    • 命令ip route-static 目的网段 子网掩码 下一跳
  • 负载分担
    • 等价路由、ECNP
    • 静态路由支持到达同一目的地的等价负载分担
  • 路由备份
    • 浮动静态路由
    • 在网中主路由失效时,浮动静态路由会加入到路由表并承担数据转发业务
  • 缺省路由
    • 目的地址和掩码都全为0
    • 如果报文的目的地址无法匹配路由表中的任何一项,路由器将选择依照缺省路由来转发报文

实验:如下拓扑,按照图上要求配置IP。

# 配置本地环回口地址
[R1]int LoopBack 1
[R1-LoopBack1]ip ad 4.4.4.4 32 

# R1上的静态路由配置
ip route-static 2.2.2.2 255.255.255.255 192.168.12.2
ip route-static 3.3.3.3 255.255.255.255 192.168.13.3
ip route-static 4.4.4.4 255.255.255.255 192.168.12.2 preference 10
ip route-static 4.4.4.4 255.255.255.255 192.168.13.3 preference 100
ip route-static 192.168.24.0 255.255.255.0 192.168.12.2 preference 10
ip route-static 192.168.34.0 255.255.255.0 192.168.12.2

# R2上的静态路由配置
ip route-static 1.1.1.1 255.255.255.255 192.168.12.1
ip route-static 3.3.3.3 255.255.255.255 192.168.12.1
ip route-static 4.4.4.4 255.255.255.255 192.168.24.4
ip route-static 192.168.13.0 255.255.255.0 192.168.12.1
ip route-static 192.168.34.0 255.255.255.0 192.168.24.4

# R3上的静态路由配置
ip route-static 1.1.1.1 255.255.255.255 192.168.13.1
ip route-static 2.2.2.2 255.255.255.255 192.168.13.1
ip route-static 4.4.4.4 255.255.255.255 192.168.34.4
ip route-static 192.168.12.0 255.255.255.0 192.168.13.1
ip route-static 192.168.24.0 255.255.255.0 192.168.34.4

# R4上的静态路由配置
ip route-static 1.1.1.1 255.255.255.255 192.168.34.3 preference 10
ip route-static 2.2.2.2 255.255.255.255 192.168.24.2
ip route-static 3.3.3.3 255.255.255.255 192.168.34.3 preference 10
ip route-static 192.168.12.0 255.255.255.0 192.168.34.3
ip route-static 192.168.12.0 255.255.255.0 192.168.24.2
ip route-static 192.168.13.0 255.255.255.0 192.168.34.3 preference 10

#进行连通性测试,Tracer跟踪查看数据转发路径
  • save保存配置,重启后配置依旧生效
  • 用户视图下执行reset saved-configuration(清空所有配置),然后reboot重启

动态路由

静态路由需要管理员手动指定路由器,如果拓扑结构发生变化,需要管理员手动去配置更改
动态路由无需管理员手动指定,可以自己通过接口学习路由,兵器会随拓扑的变化自己发生变化

  • 常见动态路由协议:RIP、OSPF、ISIS、BGP
  • 如何衡量动态路由协议的好坏
    • 正确性:能够正确找到最优的路由器,并不产生环路
    • 快收敛:当网络的拓扑结构发生变化以后,能够迅速的学习到网络中变化的网络,学习速度的快慢,称之为收敛时间
    • 开销问题:协议自身的开销,开销越低,约好
    • 安全性:协议自身不容易受到攻击,有安全机制
    • 普适性:协议是否可以适应各种拓扑结构变更及网络规模

距离矢量路由协议-RIP

  • 路由信息协议RIP(Routing Information Protocol),基于距离矢量算法的协议使用跳数作为度量来衡量到达目的网络的距离,主要用于规模较小的网络中
  • RIP宣布直连网络的主网信息
  • RIP工作原理:
    • 路由器运行RIP后,会首先发送路由更新请求(request),收到请求的路由器会发送自己的RIP路由(response)进行相应
    • 网络稳定后,路由器会周期性发送路由更新信息

实验:如图配置IP地址

# 配置环回接口地址与物理接口地址
[R1]int LoopBack  1
[R1-LoopBack1]ip ad 1.1.1.1 24 
[R1-LoopBack1]int g0/0/0
[R1-GigabitEthernet0/0/0]ip ad 12.1.1.1 24
# 相同方法配置其他路由器

# 配置RIP,对外宣告主网(宣告的为自身已知的主网)
[R1]rip 1
[R1-rip-1]network 1.0.0.0
[R1-rip-1]network 12.0.0.0
#相同方法配置其他路由器

# 连通性测试

原理

R1 R2 R3
主网 出接口 跳数 主网 出接口 跳数 主网 出接口 跳数
已知
1.0.0.0 LookBack1 0 2.0.0.0 LookBack1 0 3.0.0.0 LookBack1 0
12.0.0.0 G0/0/0 0 12.0.0.0 G0/0/0 0 23.0.0.0 G0/0/0 0
23.0.0.0 G0/0/1 0
通过RIP学习所知
2.0.0.0 G0/0/0 1 1.0.0.0 G0/0/0 1 2.0.0.0 G0/0/0 1
23.0.0.0 G0/0/0 1 3.0.0.0 G0/0/1 1 12.0.0.0 G0/0/0 1
3.0.0.0 G0/0/0 2 1.0.0.0 G0/0/0 2

当路由器学习到拓扑中所有的路由之后,会每隔30s向邻居发送一次自己完整的路由表

展开阅读全文
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值