After upgraded ESXi to 5.5, some VMs got following screenshot error when tried to edit the configuration.

“You cannot use the vSphere Client to edit the settings of virtual machines of version 10 or higher.

Use the vSphere Web Client to edit the settings of this virtual machine

1380128816114.esxi55-hardware-version-10.jpg1380128816114.esxi55-hardware-version-10.jpg 

The solution is to use vSphere Web client. The workaround for me is in following two methos:

1. Change virtualHW.version to 9 or lower

  • In ESXi, Remote VM from Inventory
  • SSH into ESXi
  • cd /vmfs/volumes/datastore1/testvm
  • VI the VM’s .VMX file
  • Find the line that says ‘virtualHW.version’. Example : virtualHW.version = “10”
  • Change the value to 8. Example : virtualHW.version = “9”
  • Register this VM back into Inventory with command “vim-cmd solo/registervm /vmfs/volumes/datastore1/testvm/testvm.vmx
hardware%2Bversion.png?resize=539%2C640hardware%2Bversion.png?resize=539%2C640

2. Use VMware Workstation 

In Workstation, in there VM’s manage menu, you can change VM’s Hardware Compatbility to Workstation 9.0 or lower, then upload it to ESXi as shown in this post step 7.

change1.png?resize=400%2C338change1.png?resize=400%2C338
change2.png?resize=400%2C343change2.png?resize=400%2C343